Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#125 closed defect (released)

Tabs lose close buttons

Reported by: ibboard Owned by:
Priority: critical Milestone: WarFoundry 0.1
Component: WarFoundry-GUI-GTK# Version:
Keywords: gui tabs close Cc:
Blocked By: Blocking: #86

Description

I don't know why (nothing errors) but when changing the size of a unit in the GTK# interface the close buttons disappear on the tabs. This is obviously not good as people can't then close tabs.

Change History (6)

comment:1 Changed 10 years ago by ibboard

Looks like it might be related to an incorrect re-labeling of the tab when the unit name changes.

comment:2 Changed 10 years ago by ibboard

Probably caused by this line that just calls SetTabLabelText on the notebook page.

comment:3 Changed 10 years ago by ibboard

Resolution: fixed
Status: newclosed

(In r224) Fixes #125: Tabs lose close buttons

  • Use "CreateNotebookTabLabelWithClose" to set label on name change instead of setting label text (added in ibboard:r100)

comment:4 Changed 10 years ago by ibboard

released: 1

Mark released changes as released

comment:5 Changed 10 years ago by ibboard

released: 1yes

Mark released fixes as released using radio values

comment:6 Changed 10 years ago by ibboard

Resolution: fixedreleased

Mark fix as released under a previous version

Note: See TracTickets for help on using tickets.