Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#145 closed task (released)

Add UI to remove units from army

Reported by: ibboard Owned by:
Priority: major Milestone: WarFoundry 0.1
Component: WarFoundry-GUI-GTK# Version:
Keywords: command unit remove delete Cc:
Blocked By: Blocking: #86

Description

There is currently a IBBoard.WarFoundry.API.Commands.RemoveUnitCommand to delete units from an army, but it appears to be unused by either UI. This leaves us with UIs that can keep adding and adding units but never remove them!

Change History (8)

comment:1 Changed 10 years ago by ibboard

(In r235) Re #145: Add UI to remove units from army

  • Add initial right-click "remove unit" for GTK app

Existing problems:

  • Right-click occurs before selection changes, so it can be a click out of synch

comment:2 Changed 10 years ago by ibboard

Only actually a GTK# problem - WinForms already has code for deleting units (Google search of site didn't turn it up and I was only working from web info).

Thought on update problem - look at GetDestRowAtPos() to get row to update selection when right-clicking?

comment:3 Changed 10 years ago by ibboard

Component: WarFoundry-GUIsWarFoundry-GUI-GTK#

Change to correct component.

comment:4 Changed 10 years ago by ibboard

Blocking: 86 added

comment:5 Changed 10 years ago by ibboard

Status: newconfirmed

Move tickets to new "confirmed" status to show that they've been checked

comment:6 Changed 10 years ago by ibboard

(In r648) Re #145: Add UI to remove units from army

  • Fix the delay in right-click menu caused by out of sync selection

Re #86: Complete initial GTK# UI

  • Make unit creation create a tab

comment:7 Changed 10 years ago by ibboard

Resolution: fixed
Status: confirmedclosed

(In r649) Fixes #145: Add UI to remove units from army

  • Remove tab on unit deletion
  • Remove tab from widget map on close

Also:

  • Alias IBBoard.WarFoundry.API.Objects to make access easier (Unit clashes with a GTK class)

comment:8 Changed 9 years ago by ibboard

Resolution: fixedreleased

Released in WF GTK v0.1 beta 1

Note: See TracTickets for help on using tickets.