Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#149 closed defect (released)

Crash caused by edit on null tree item

Reported by: Henri Owned by: Henri
Priority: minor Milestone: WarFoundry 0.1
Component: WarFoundry-GUI-WinForms Version:
Keywords: nullpointer armytree Cc:
Blocked By: Blocking:

Description

I was opening and closing a test army when I get a "crash" window. Apparently not serious because I could resume and there seems to not be any ill effects.

Attachments (1)

crash.txt (4.4 KB) - added by Henri 10 years ago.
Crash details as reported by Windows

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by Henri

Attachment: crash.txt added

Crash details as reported by Windows

comment:1 Changed 10 years ago by ibboard

Keywords: nullpointer added
Milestone: WarFoundry 0.1
Summary: Random "crash"Crash caused by edit on null tree item

It looks like the "edit the selected unit in the tree" code makes an invalid assumption at one point (it assumes it'll always have a unit when it doesn't). Should be easy enough to fix.

comment:2 Changed 10 years ago by ibboard

Keywords: armytree added

comment:3 Changed 10 years ago by ibboard

Owner: set to ibboard
Status: newaccepted

comment:4 Changed 10 years ago by ibboard

Resolution: worksforme
Status: acceptedclosed

Unable to reproduce and code looks like it should all be initialised or checked. A way of reproducing needs to be found so that it can be tested.

comment:5 Changed 10 years ago by ibboard

Resolution: worksforme
Status: closedreopened

comment:6 Changed 10 years ago by ibboard

Owner: changed from ibboard to Henri
Status: reopenedneedinfo

comment:7 Changed 10 years ago by ibboard

Resolution: fixed
Status: needinfoclosed

(In r254) Fixes #149: Crash with edit on null tree item

  • Clean up code - can't seem to recreate

comment:8 Changed 10 years ago by ibboard

released: 1

Mark released changes as released

comment:9 Changed 10 years ago by ibboard

released: 1yes

Mark released fixes as released using radio values

comment:10 Changed 10 years ago by ibboard

Resolution: fixedreleased

Mark fix as released under a previous version

Note: See TracTickets for help on using tickets.