Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#179 closed defect (released)

Make sure that translations are used throughout UI

Reported by: ibboard Owned by: ibboard
Priority: major Milestone: WarFoundry 0.1
Component: WarFoundry-GUI-WinForms Version: Unknown or N/A
Keywords: translation Cc:
Blocked By: Blocking: #88, #203

Description

We've now got quite a few possible translation languages, so the code needs checking to find and fix all of the places that have been lazy and either haven't used translations at all or have used translations but not defined the English translation and are just relying on falling back to the supplied hard-coded string.

Change History (15)

comment:1 Changed 9 years ago by ibboard

Status: newconfirmed

Move tickets to new "confirmed" status to show that they've been checked

comment:2 Changed 9 years ago by ibboard

Blocking: 203 added

comment:3 Changed 9 years ago by ibboard

(In r327) Re #179: Make sure that translations are used throughout UI

  • Put names back on menu items
  • Add some more translation calls
  • Make some extra items translatable
  • Update English translation file

comment:4 Changed 9 years ago by ibboard

(In r370) Re #88: Complete initial WinForms UI

  • Add basic initial "about" box
  • Translations (below)

Re #179: Make sure that translations are used throughout UI

  • Make all controls translatable
  • Supply translations for all controls

Re #204: Use new limits in WinForms UI

  • Warn the user and cap the number if we try to go out of range for equipment

comment:5 Changed 9 years ago by ibboard

(In r372) Re #179: Make sure that translations are used throughout UI

  • Add missed translations

comment:6 Changed 9 years ago by ibboard

(In r373) Re #179: Make sure that translations are used throughout UI

  • Translate context menu on army tree
  • Translate warning messages in main form
  • Add translation strings

comment:7 Changed 9 years ago by ibboard

(In r378) Re #179: Translations throughout GUI

  • Add translation for "equip all" radio button on equipment editing

comment:8 Changed 9 years ago by ibboard

(In r405) Fixes #220: Make percentage and numeric amounts more obvious

  • Differentiate between "free" and costed and build up a new string with more options
  • Make use of translations for all of the parts of the line

Re #179: Make sure that translations are used throughout UI

  • Add new translations to file

comment:9 Changed 9 years ago by ibboard

(In r408) Re #179: Make sure that translations are used throughout UI

  • Fix locations in the API that are used in the front-end

comment:10 Changed 9 years ago by ibboard

(In r409) Re #179: Make sure that translations are used throughout UI

  • Intermediary fix for locations in the UI for amount translations

comment:11 Changed 9 years ago by ibboard

Owner: set to ibboard
released: no
Status: confirmedaccepted
Version: Unknown or N/A

comment:12 Changed 9 years ago by ibboard

(In r412) Re #179: Make sure that translations are used throughout UI

  • Add translations to file that were added in r410

comment:13 Changed 9 years ago by ibboard

Resolution: fixed
Status: acceptedclosed

(In r421) Fixes #179: Make sure that translations are used throughout UI

  • Translate tooltip for "total points" panel
  • Add translation for tooltip to English file
  • Change some default messages to default capitalisation and sensible values

Also:

  • Bump version to v0.1b6pre (looks like v0.1b5 is still showing itself as v0.1b4!)

comment:14 Changed 9 years ago by ibboard

released: noyes

Release as part of v0.1b6

comment:15 Changed 9 years ago by ibboard

Resolution: fixedreleased

Mark fix as released under a previous version

Note: See TracTickets for help on using tickets.