Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#243 closed task (released)

Create "New Army" dialog in Qt# app

Reported by: ibboard Owned by: ibboard
Priority: major Milestone: WarFoundry 0.1
Component: WarFoundry-GUI-Qt# Version: Trunk
Keywords: qt ui create army Cc:
Blocked By: Blocking: #242

Description

The Qt# version of WarFoundry needs a "Create Army" dialog, similar to the WinForms one.

Change History (8)

comment:1 Changed 9 years ago by ibboard

Status: newconfirmed

Confirm all Qt# sub-tickets

comment:2 Changed 9 years ago by ibboard

Owner: set to ibboard
Status: confirmedaccepted

comment:3 Changed 9 years ago by ibboard

(In r466) Re #242: Qt# UI

  • Make use of icons

Re #243: Create "New Army" dialog in Qt# app

  • Create initial rendering of dialog (non-functional)

Re #247: Implement menu options in Qt# app

  • Add initial hook for New Army dialog from menu item

comment:4 Changed 9 years ago by ibboard

(In r467) Re #243: Create "New Army" dialog in Qt# app

  • Remove unnecessary delegate creation and use built-in auto-delegate wrapping
  • Remove unnecessary marking as "signal" method - not needed when using delegates

comment:5 Changed 9 years ago by ibboard

(In r469) Re #242: Create Qt# UI for WarFoundry

  • Fix warnings about Connect strings not being signals

Re #243: Create new Qt# "Create Army" dialog

  • Change from List View to List Widget (views need models, which only handle QVariants and not arbitrary objects)
  • Populate Game System list
  • Populate races list on game system selection changed
  • Set text on some labels

comment:6 Changed 9 years ago by ibboard

(In r474) Re #243: Create "New Army" dialog in Qt# app

  • Disable "OK" button on army creation form
  • Add event hooks and methods to enable OK Button when all values are completed
  • Set properties on spinbox

Still need to work out how to stop dialog showing up in task bar.

comment:7 Changed 9 years ago by ibboard

Resolution: fixed
Status: acceptedclosed

(In r478) Fixes #243: Create "New Army" dialog in Qt# app

  • Make dialog not show in task bar (add parent to constructor)
  • Add methods to retrieve values

Re #242: Create Qt# UI for WarFoundry

  • Copy lots of implementation from the WinForms app to get some core army loading working

(looks like we need to investigate refactoring commonality)

comment:8 Changed 9 years ago by ibboard

Resolution: fixedreleased

Mark fix as released under a previous version

Note: See TracTickets for help on using tickets.