Opened 9 years ago

Closed 9 years ago

#339 closed defect (worksforme)

WarFoundry and Forge have incompatible "number formats" in datafiles

Reported by: Henri Owned by:
Priority: major Milestone: WarFoundry API 0.2
Component: WarFoundry Forge Version: Trunk
Keywords: Cc:
Blocked By: Blocking:

Description

When trying to open files I ran into multiple layers of "value not right for property X". First it was the defaultArmyValue, now I'm getting it on the maxPoints.

The reason for it which I ran into with the API and WF main is that some of the controls are numericUpDown (or whatever they are called) which are "decimal" whereas most numbers in WF are Ints.

So either WF needs to be changed so all numbers are put into decimal or the Forge needs to convert them before using them. I think having the Forge change them as needed is probably the better idea.

Change History (3)

comment:1 Changed 9 years ago by Tsudico

Status: newneedinfo_new

snowblizz,

Could you list the revision you are using as well as add an attachment of the system file that loads incorrectly? I am unable to reproduce the problem with revision [17/WarFoundryForge].

As far as I know, because the system values are integers the numeric controls will just convert them to floats or doubles as needed. This is called upcasting and shouldn't throw an error. Additionally, the controls limit the value to only whole numbers so they should be able to be type cast back into an integer with no problem.

comment:2 Changed 9 years ago by Henri

I am now also unable to reproduce any error. I was using that revision as well.

Hopefully then it was some issue created by my specific set-up of references and working with the code. If I get it again I'll try to be more specific. It was totally there though, I'm not imagining things. Much. ;-)

comment:3 Changed 9 years ago by Henri

Resolution: worksforme
Status: needinfo_newclosed
Note: See TracTickets for help on using tickets.