Opened 10 years ago

Closed 8 years ago

#161 closed defect (fixed)

Re-implement "load last used game system by default" in WinForms

Reported by: ibboard Owned by: ibboard
Priority: major Milestone: WarFoundry WinForms 0.2
Component: WarFoundry-GUI-WinForms Version:
Keywords: gamesystem startup preferences Cc:
Blocked By: Blocking:

Description

The GTK# UI loads a listed game system from the preferences by default on startup (or it could be from the command-line). This was tried at one point in WinForms, but caused exceptions because of thread access issues when the setting of the game system triggered a UI update. The functionality should be re-added so that users of just one game system don't have to keep picking a game system each time.

Change History (4)

comment:1 Changed 10 years ago by ibboard

(In r285) Re #161: Re-implement "load last used game system by default" in WinForms

  • Add same stub as GTK# - load game system defined by preferences, but don't save last used yet

comment:2 Changed 10 years ago by ibboard

Status: newconfirmed

Move tickets to new "confirmed" status to show that they've been checked

comment:3 Changed 9 years ago by ibboard

Milestone: WarFoundry 0.2WarFoundry WinForms 0.2

Separate UI milestones from API milestones

comment:4 Changed 8 years ago by ibboard

Owner: set to ibboard
Resolution: fixed
Status: confirmedclosed

In [913]:

Fixes #161: Re-implement "load last used game system by default" in WinForms

  • Save game system on change
Note: See TracTickets for help on using tickets.