Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#253 closed enhancement (fixed)

Allow multiple data files in a single zip

Reported by: ibboard Owned by: ibboard
Priority: major Milestone: WarFoundry API 0.2
Component: WarFoundry-API Version: Trunk
Keywords: native data file zip pack Cc:
Blocked By: Blocking:

Description

The default WarFoundry data files assume that only a single file is contained within them. This is probably bad practice and inflexible. It would be useful to be able to create entire system "packs" that contained the system data file and all races for that system.

Change History (12)

comment:1 Changed 9 years ago by ibboard

Status: newconfirmed

comment:2 Changed 9 years ago by ibboard

Milestone: WarFoundry 0.2WarFoundry API 0.2

Separate API milestone from UI milestone

comment:3 Changed 8 years ago by ibboard

Owner: set to ibboard
Status: confirmedaccepted

comment:4 Changed 8 years ago by ibboard

In [798]:

Re #253: Allow multiple data files in a single zip

  • Add test data and initial test

comment:5 Changed 8 years ago by ibboard

In [799]:

Re #253: Allow multiple data files in a single zip

  • Rebuild file loading to start to allow multiple files in a native file

comment:6 Changed 8 years ago by ibboard

In [800]:

Re #253: Allow multiple data files in a single zip

  • Update Mock factory to work properly

comment:7 Changed 8 years ago by ibboard

In [801]:

Re #253: Allow multiple data files in a single zip

  • Add event-based mechanism to allow GameSystem to be registered before Race is loaded from a single zip

comment:8 Changed 8 years ago by ibboard

In [802]:

Re #253: Allow multiple data files in a single zip

  • Add and use loader that just listens to events to capture new objects and does nothing else

comment:9 Changed 8 years ago by ibboard

In [803]:

Re #253: Allow multiple data files in a single zip

  • Make registration methods virtual to allow implementations to do extra things on register

comment:10 Changed 8 years ago by ibboard

In [804]:

Re #253: Allow multiple data files in a single zip

  • Differentiate in simple cache by concating strings
  • Add extra tests for .race file and non-default names

comment:11 Changed 8 years ago by ibboard

Resolution: fixed
Status: acceptedclosed

Seems to be working fine. Any further refinements (e.g. for non-native loaders or general refactoring) can come later.

comment:12 Changed 8 years ago by ibboard

In [819]:

Re #253: Allow multiple data files in a single zip

  • Fix unit tests by unsubscribing at end of test

no-open-ticket

Note: See TracTickets for help on using tickets.