Opened 6 years ago

Last modified 5 years ago

#400 needinfo_new defect

WarFoundry on ubuntu 12.04(x64)

Reported by: Morbid Owned by:
Priority: critical Milestone: WarFoundry GTK 0.2
Component: General/Unknown Version: WarFoundry 0.1
Keywords: Cc:
Blocked By: Blocking:

Description

Try to run WarFoundry-GTK and get the following error log:

FATAL [02:04:16]: FrmMainWindow.HandleUnhandledException() - Line: 0 - (System.MissingMethodException) Method not found: 'System.Type.op_Inequality'.
System.MissingMethodException: Method not found: 'System.Type.op_Inequality'.
  at IBBoard.GtkSharp.Translatable.TranslatableWindow..ctor (WindowType windowType) [0x00000] in <filename unknown>:0 
  at IBBoard.GtkSharp.Translatable.TranslatableWindowWithActions..ctor (WindowType windowType) [0x00000] in <filename unknown>:0 
  at IBBoard.WarFoundry.GUI.GTK.FrmMainWindow..ctor (System.String[] args) [0x00000] in <filename unknown>:0 
  at IBBoard.WarFoundry.GUI.GTK.FrmMainWindow.Main (System.String[] args) [0x00000] in <filename unknown>:0


Attachments (1)

Ubuntu12.04-Warfoundry.png (197.4 KB) - added by ibboard 6 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by ibboard

Reported in this thread. The problem is that Ubuntu/Debian now compile GTK# (and other core libraries) using .Net 4.0 profiles but we still target 2.0 for widest compatibility.

Running the app as:

mono --runtime=v4.0 /path/to/WarFoundry-GTK.exe

should (apparently) fix the problem by forcing it to run 2.0 code as 4.0 code, but Morbid just got the following instead:

INFO  [02:04:55]: FrmMainWindow..ctor() - Line: 0 - Opening FrmMainWindow
DEBUG [02:04:55]: FrmMainWindow..ctor() - Line: 0 - Loading preferences
DEBUG [02:04:55]: FrmMainWindow..ctor() - Line: 0 - Loading translations
DEBUG [02:04:55]: FrmMainWindow..ctor() - Line: 0 - Initialising
DEBUG [02:04:55]: FrmMainWindow..ctor() - Line: 0 - Initialising complete - seeing if we can load default army or system
INFO  [02:04:12]: FrmMainWindow.OnWindowDestroyed() - Line: 0 - Exiting
DEBUG [02:04:12]: FrmMainWindow.Main() - Line: 0 - Application ended

More investigation (and an Ubuntu VM) is required.

Changed 6 years ago by ibboard

Attachment: Ubuntu12.04-Warfoundry.png added

comment:2 Changed 6 years ago by ibboard

I've just tried recreating this in Ubuntu 12.04 b2 using a live CD in a VM and have recreated the initial failure, but not the failure with "--runtime".

Mono isn't on the live distro, so I had to install mono-runtime, libmono-posix4.0-cil and libgtk2.0-cil, but after that it worked (see screenshot).

Please can you run the following command and attach the file it creates:

dpkg -l '*cil*' | grep "ii " > packages.txt && dpkg -l '*mono*' | grep "ii " >> packages.txt

comment:3 Changed 6 years ago by ibboard

Just realised I was using the latest nightly, but you've reported this against v0.1. If you were using v0.1, can you also test the latest nightly and see if that works with the "--runtime" switch?

comment:4 Changed 6 years ago by ibboard

Status: newneedinfo_new

comment:5 Changed 5 years ago by ibboard

Keywords: can't run removed
Milestone: WarFoundry GTK 0.1WarFoundry GTK 0.2

comment:6 Changed 5 years ago by ibboard

May have been fixed (or at least bodged over) as part of #417, but still needs checking and confirming on other installs.

Note: See TracTickets for help on using tickets.