Opened 10 years ago

Closed 9 years ago

#238 closed enhancement (fixed)

subfolders datafolder

Reported by: terry Owned by: ibboard
Priority: minor Milestone: WarFoundry API 0.2
Component: WarFoundry-API Version: Unknown or N/A
Keywords: papercut load directory Cc:
Blocked By: Blocking:

Description

It would be handy to let warfoundry look in sub folders of the data folders, so you can order the game systems beter.

Change History (6)

comment:1 Changed 10 years ago by ibboard

Milestone: WarFoundry 1.0
Status: newconfirmed

Target v1.0, but may be fixed quicker as it would be quite easy to add.

comment:2 Changed 9 years ago by ibboard

Keywords: papercut load directory added

comment:3 Changed 9 years ago by ibboard

Milestone: WarFoundry 1.0

Milestone WarFoundry 1.0 deleted

comment:4 Changed 9 years ago by ibboard

Component: General/UnknownWarFoundry-API
Milestone: WarFoundry API 0.2

Target 0.2 API as it should be really quick. Should work with something along the lines of:

foreach (DirectoryInfo subdir in directory.GetDirectories())
{
FillLoadableFilesForDirectory(loadableRaces, loadableGameSystems, subdir);
}

within FillLoadableFilesForDirectory method of AbstractWarFoundryLoader.cs

comment:5 Changed 9 years ago by ibboard

In [772]:

Re #238: subfolders datafolder

  • Add support for recursing sub-folders

comment:6 Changed 9 years ago by ibboard

Owner: set to ibboard
Resolution: fixed
Status: confirmedclosed

In [773]:

Fixes #238: subfolders datafolder

  • Add unit test and mock object to test loading from sub-folders. We use any old file because it will fail to load it and report a failure without relying on loading logic.
Note: See TracTickets for help on using tickets.