Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#86 closed task (released)

Complete initial GTK# UI

Reported by: ibboard Owned by:
Priority: major Milestone: WarFoundry GTK 0.1
Component: WarFoundry-GUI-GTK# Version: Unknown or N/A
Keywords: Cc:
Blocked By: #60, #69, #79, #87, #96, #125, #129, #138, #143, #145, #182, #263, #264, #305, #306, #307, #308, #309 Blocking:

Description

Parent ticket for various UI tasks.

Change History (35)

comment:1 Changed 10 years ago by ibboard

Blocked By: 87 added

comment:2 Changed 10 years ago by ibboard

(In r132) Re #10 (Code readability) and Re #86 (Complete GTK# GUI):

  • Update UnitDisplayWidget to use new way of getting unit stats

comment:3 Changed 10 years ago by ibboard

Owner: ibboard deleted

Remove owner so that the team can more easily see bugs. Using default owners seems good at first but is bad practice when a team can be working on any part of the project.

comment:4 Changed 10 years ago by ibboard

(In r137) Re #86: Complete initial GTK# UI

  • Make use of new GTK# util code to add close button to tab

comment:5 Changed 10 years ago by ibboard

(In r195) Re #86: Initial GTK# GUI

  • Add GTK# icons to menus where a sensible one exists

comment:6 Changed 10 years ago by ibboard

(In r196) Re #86: Initial GTK# GUI (because of Re #53)

  • Refactor file saving in to a common method
  • Replace fixed location with dialog

comment:7 Changed 10 years ago by ibboard

Blocked By: 125 added

comment:8 Changed 10 years ago by ibboard

(In r206) Re #86: Complete initial GTK# UI

  • Enable "open" buttons now that saving is starting to work

comment:9 Changed 10 years ago by ibboard

(In r209) Re #86: Complete initial GTK# UI

  • Enable "open" buttons
  • Fill out "open" method
  • Fix showing of "save failed" dialog

comment:10 Changed 10 years ago by ibboard

Blocked By: 79, 96 added

comment:11 Changed 10 years ago by ibboard

Blocked By: 138 added

comment:12 Changed 10 years ago by ibboard

(In r284) Re #86: Complete GTK# UI

  • Make save buttons enable when a change has been made, whether the file was saved or not
  • Make the Save button default to "Save As" behaviour if the file hasn't been saved before
  • Make sure that loaded file path is kept and that it is wiped on file load

comment:13 Changed 10 years ago by ibboard

Blocked By: 182 added

comment:14 Changed 10 years ago by ibboard

Blocked By: 129, 143, 145 added

comment:15 Changed 10 years ago by ibboard

Status: newconfirmed

Move tickets to new "confirmed" status to show that they've been checked

comment:16 Changed 10 years ago by ibboard

(In r457) Re #86: Complete initial GTK# UI

  • Add default config file to build
  • Auto-updates of source code

comment:17 Changed 10 years ago by ibboard

Blocked By: 263 added

comment:18 Changed 10 years ago by ibboard

Blocked By: 264 added

comment:19 Changed 9 years ago by ibboard

(In r644) Re #86: Complete initial GTK# UI

  • Add sln to make solution loading easier
  • Commit rebuild UI files

comment:20 Changed 9 years ago by ibboard

(In r647) Re #86: Complete initial GTK# UI

  • Keep UI tidier by hiding category tree until we have an army
  • Implement reloading files

comment:21 Changed 9 years ago by ibboard

(In r648) Re #145: Add UI to remove units from army

  • Fix the delay in right-click menu caused by out of sync selection

Re #86: Complete initial GTK# UI

  • Make unit creation create a tab

comment:22 Changed 9 years ago by ibboard

(In r650) Fixes #138: Re-implement menu for undo/redo

  • Replace WinForms code with equivalent GTK objects to construct menu and handle multi-undo/redo

Re #86: Complete initial GTK# UI

  • Make tabs re-orderable
  • Make tabs scrollable when we get too many

comment:23 Changed 9 years ago by ibboard

(In r652) Re #86: Complete initial GTK# UI

  • Add "notes" section to unit tab

comment:24 Changed 9 years ago by ibboard

Blocked By: 305 added

comment:25 Changed 9 years ago by ibboard

Blocked By: 306 added

comment:26 Changed 9 years ago by ibboard

Blocked By: 307 added

comment:27 Changed 9 years ago by ibboard

Blocked By: 308 added

comment:28 Changed 9 years ago by ibboard

Blocked By: 309 added

comment:29 Changed 9 years ago by ibboard

(In r653) Re #86: Complete GTK# UI

  • Make keypad "enter" work for confirming unit name

comment:30 Changed 9 years ago by ibboard

In [718]:

Re #86: Complete initial GTK# UI

  • Fix default game system selecting

comment:31 Changed 9 years ago by ibboard

In [733]:

Re #86: Complete initial GTK# UI

  • Add About dialog
  • Make sure app builds as "WarFoundry-GTK.exe"
  • Move all UI components to IBBoard.WarFoundry.GUI.GTK namespace

comment:32 Changed 9 years ago by ibboard

In [734]:

Re #86: Complete initial GTK# UI

  • Make sure that undo/redo are not sensitive on first opening app

comment:33 Changed 9 years ago by ibboard

Milestone: WarFoundry 0.1WarFoundry GTK 0.1

Separate UI milestone from API milestone

comment:34 Changed 9 years ago by ibboard

Resolution: fixed
Status: confirmedclosed
Version: Unknown or N/A

All sub-tickets now complete. Now to await testing!

comment:35 Changed 9 years ago by ibboard

Resolution: fixedreleased

Released as part of WF GTK# v0.1 RC1

Note: See TracTickets for help on using tickets.